Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Im Outlook Add-In u.a. Antwortlink ausgegraut
#1
Question 
Hallo.

Wir wollen endlich das Outlook Add-In ausrollen. Soll in den nächsten Wochen beim Wechsel auf neue Citrix-Server dann gleich mit dabei sein.

Add-In ist auf dem Server installiert und die Einstellungen sind per GPO vorgegeben. Die Einstellungen der GPO sind identlisch auf meinem Windows 10 Client und hier ist das Add-In lokal auch mit inistalliert.

Am Win10 Client sind alle gewünschten Optionen nutzbar. In Citrix sind unter "Large Files" drei Buttons ausgegraut (s. angehängter Screenshot).

Ich vermute, dass es hier mal wieder um Netzwerkkommunikation vom Clitrix-Server zum NSP-Server geht. Jedoch habe ich in den Dokumentationen irgendwie die genauen Angaben zu notwendigen Firewall-Freischaltungen zwischen Outlook Add-In und NSP-Servern nicht mehr gefunden.

Könnt Ihr mir mitteilen, was ich wegen der 3 ausgegrauten Optionen prüfen kann?

Optional könnte es noch sein, dass es an in Citrix zu nutzenden Proxy liegt. Dieser KB-Artikel nennt dies ja ganz unten. ABER: gilt evtl. gar nicht mehr für NSP 13.x.

Hoffe, Ihr könnt mir den entscheidenden Hinweis geben. Danke.


Angehängte Dateien Thumbnail(s)
   
Gruß,
Martin
Zitieren
#2
Hallo mabu,

grundsätzlich ist das Web Portal stets über tcp/443 zu erreichen und zu nutzen. Nutze ich meinen Outlook Client außerhalb meiner internen Infrastruktur, ist zum Web Portal (Internet > Web Portal) auch nur das HTTPS- Protokoll freigeschaltet. Ich nutze Split-DNS und daher ist die interne und externe Web Portal Adresse bei mir identisch. Mit dieser Konfiguration ist die Funktionsweise bei mir stets überall gegeben.

Grundsätzlich musst Du also prüfen, ob deine Citrix Umgebung das Web Portal über tcp/443 erreichen kann (Proxy-/Firewalleinstellungen).

Nur frage ich mich selbst gerade, ob das Plugin stets die Erreichbarkeit des Web Portals prüft und deswegen die Buttons nach belieben ein- und ausblenden kann? Oder ob hier ein anderes Problem ggf. vorliegt? ;-)

Viele Grüße,
André

Hallo mabu,

nutzen die W10 Clients dieselben GPOs wie die Citrix Umgebung? Ansonsten die GPO-Richtlinie "Gemeinsames Passwort des Web Portals:" prüfen, ob dieser korrekt gesetzt ist bzw. ob die entsprechende GPO denn überhaupt erfolgreich in der Citrix Sitzung angewendet wird?

Viele Grüße,
André
Zitieren
#3
Hallo André.

Wir haben auch Split-DNS eingerichtet, um die gleiche URL intern wie extern nutzen zu können.

Die GPO ist für die Citrix-Server und für meinen Client absolut identisch. Eben zur Sicherheit auch das "gemeinsame Passwort" noch einmal verglichen.

Habe es eben in Citrix mal ohne Proxy probiert und im Browser auf das Portal zugegriffen (also mit https). Dauert ein wenig (da wird ja wohl auch irgendeine externe Seite angefragt - jquery... oder so). Aber das Portal wird dann angezeigt. Somit gehe ich mal davon aus, dass der Zugriff über Port 443  von Citrix zum Portal funktioniert. Geht ja nun nicht mehr über den Proxy.

Weiterhin ratlos. Warte noch mal ein wenig ab, ob noch weitere Antworten kommen. Ansonsten muss ich doch ein Ticket eröffnen.
Gruß,
Martin
Zitieren
#4
Werden die Buttons sofort ausgegraut angezeigt oder erst nach Eingabe einer Adresse?

Wir hatten das Problem, dass .com-Adressen dazu geführt haben, dass die Buttons ausgegraut waren. Grund hierfür war der UrlScan auf dem Server, um die zu verarbeitenden http-Requests zu beschränken. Dazu gehören Requests, die auf .exe, .cmd aber auch .com enden. Das Plugin prüft die Adressen nach Eingabe durch Aufruf von:
https://<link-to-large-file>/enqsig/api/upload/Settings/alias@example.com

Gut möglich, dass das hier ein anderes Verhalten ist - aber vielleicht ist der UrlScan-Hinweis an anderer Stelle hilfreich.


Viele Grüße,
Patrick
Zitieren
#5
Guten Morgen Martin,

hattest Du auch geprüft, ob die GPO in der Citrix Sitzung tatsächlich angewendet worden ist? Am besten mit rsop.msc mal in der Citrix Sitzung austesten bzw. das erstellte Ergebnis daraufhin untersuchen! ;-)

Vielen Dank und gesunde Grüße,
André
Zitieren
#6
Hallo zusammen,

das klingt in der Tat merkwürdig. Das Outlook Add-In überprüft in der Tat, ob es das Web Portal erreichen kann. Wenn das nicht gegeben ist, werden jedoch alle Buttons im Large Files Bereich ausgegraut. Ist es denn möglich, über den "Hochladen" Knopf eine Datei hochzuladen?

Gruß Stefan
Zitieren
#7
Hallo zusammen.

Erstmal zur GPO: auf dem Citrix-Server sind die Einträge unter "HKCU\Software\Policies\Net at Work GmbH\Net at Work MailGateway\Outlook AddIn" zu finden. Iddentisch zu den 5 Einträgen bei mir auf dem Win10-PC. Vor allem auch gleiches SharedSecret.

Im Browser komme ich in Citrix-Sitzung auf die https-URL unter "WebPortalURL". Aber da ist es definitiv über den Proxy.

Der Tip mit "Hochladen" ausprobieren bringt dann in Citrix tatsächlich Fehlermeldung (am PC mit gleicher Datei klappt es) - "authenticationrequired". Aber SharedSecret ist da und gleich  Undecided


Ich hänge mich hier irgendwie immer noch am Proxy auf. Und da scheint es irgendwie einen Zusammenhang zu geben.
  1. im IE unter Verbindungen den Eintrag zum Proxy-Skript ausgeschaltet und Outlook gestartet
  2. Outlook benötigt ziemlich lange für den Start - aber dann ist in neuer Mail im NSP-AddIn alles okay Smile (Datei wird auch hochgeladen)
Nach Sichtung des Proxy-Skriptes muss die URL des NSP-WebPortals in den Bereich, der den Weg ohne Proxy zurückgibt.

Denke, dass Problem ist damit dann gelöst.

Danke für die Unterstützung. Da hätte ich noch länger nicht gesucht.

Wünsche alles Gute.
Gruß,
Martin
Zitieren
#8
Gern geschehen! :-) Dafür sind wir ja da. 

Gruß Stefan
Zitieren
#9
Hallo Stefan,
eine Frage im indirekten Zusammenhang zum Problem: NSP bzw. das Add-On unterstützt/supportert Proxy Server?


Gruß,
Daniel
Zitieren
#10
Hallo Daniel,

das Outlook Add-In nutzt die Proxy-Einstellungen des Clients. Die Frage kann ich also reinen Gewissens mit Ja beantworten. Man sollte allerdings genauer hinschauen. Manche Proxies verhalten sich in diesen Verbindungen recht seltsam. Im Fehlerfall solltest Du also auch den Proxy mit in die Fehleranalyse ziehen.

Gruß Stefan
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 3 Gast/Gäste